Skip to main content
Version: v2.2.x LTS

Software requirements for Zowe CLI plug-ins

Software requirements for Zowe CLI plug-ins

Before you use Zowe™ CLI plug-ins, complete the following steps:

Important! You can perform the required configurations for the plug-ins that you want to use before or after you install the plug-ins. However, if you do not perform the required configurations, the plug-ins will not function as designed.

Plug-inRequired Configurations
IBM CICS Plug-in for Zowe CLI
IBM Db2 Database Plug-in for Zowe CLI
  • Download and prepare the ODBC driver (required for only package installations) and address the licensing requirements. Perform this task before you install the plug-in.
  • (MacOS) Download and Install Xcode.
IBM z/OS FTP Plug-in for Zowe CLI
  • Ensure that z/OS FTP service is enabled and configured with JESINTERFACELEVEL = 2.
  • FTP over SSL is recommended.
IBM IMS Plug-in for Zowe CLI
IBM MQ Plug-in for Zowe CLI
Visual Studio Code Extension for Zowe
  • Node.js V8.0 or later
  • Access to z/OSMF; at least one profile is configured
  • Configure TSO/E address space services, z/OS data set, file REST interface, and z/OS jobs REST interface. For more information, see z/OS Requirements.

Important! You can perform the required configurations for the plug-ins that you want to use before or after you install the plug-ins. However, if you do not perform the required configurations, the plug-ins will not function as designed.